Jump to content

Welcome to the brand new 205GTIDrivers.com website! We hope you'll enjoy it! Read the full notice here.

  • Welcome to 205GTIDrivers.com!

    Hello dear visitor! Feel free to browse but we invite you to register completely free of charge in order to enjoy the full functionality of the website.

Search the Community

Showing results for tags 'pump'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Technical Articles & Guides
    • 205 GTI Basics & Buying Guides
    • Engine Maintenance & Upgrades
    • Gearbox & Drivetrain
    • Brakes, Suspension & Steering
    • Body, Interior and ICE
    • Misc & General Technical
  • Our Partners
  • Car Photo of the Month

Forums

  • Links
    • 205 GTI Drivers Main Website
  • Support and News
    • Website & Forum Updates and News
  • Technical
    • XU 8v Engine Maintenance and Performance Upgrades
    • XU 16v Engine Maintenance and Performance Upgrades
    • XU Engine & Gearbox Service and Maintenance - ARCHIVE
    • XU Engine & Gearbox Modifications and Performance Upgrades - ARCHIVE
    • TU Engine Maintenance and Performance Upgrades
    • Non-XU/TU Engine Maintenance and Performance Upgrades
    • Aftermarket Engine Management Systems
    • Gearbox & Drivetrain
    • Brakes, Suspension & Steering
    • Body, Interior & ICE
    • Misc/General Technical
    • Other Model-specific Technical Questions
    • Technical Archive
    • 405Mi16.com Technical Forums Archive
  • General
    • General Car Chat
    • Drivers' Cars Discussion Topics
  • Car Projects & Works
    • Large Scale & Special Projects
    • Car Restorations, Overhauls & Upgrades
    • Trackday & Race/Rally Prep
    • Engine Work
    • Body, Misc & Non-Car Work
    • Projects & Works Starters
  • For Sale, Wanted and Group Buys
    • PugsForSale.co.uk Classifieds

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 5 results

  1. Only 6 months ago a bought the complete new fuel pump and housing for my 1.9 GTi. It's been sat doing nothing since. Today I tried starting it, quickly realised there was no fuel being pumped. Am getting elec supply to pump so removed pump to test it by connecting direct to battery. Nothing doing :-(. No sound of spinning or pumping. The damn thing has only been in there 6 months!! Is this a common problem? SURELY these things are designed to sit in fuel for YEARS without seizing up?? Obviously the pump is a completely sealed unit. Any suggestions for freeing it up, or a make to buy that won't seize after 6 months??
  2. Hi everybody. Can anyone help me out. I want to replace the fuel pump on my 205 gti 1.9. Can't find anything on "how to" or a guide to do it. If anyone can help me, it would be great. Also what pump to use? Thanks!!
  3. Hi . My Fuel pump has died and I'm in search of a new After Market one locally. What fuel pressure I need to be looking for ? or any detail.. Thanks
  4. Hi all, Ive got a rack ive rebuilt myself using locally manufactured (australian) seals to rebuilt a 205 Si rack (so non-gti rack which has 2.8ish turns opposed to 3.2) using std spline drive. engine is an rfs gti6 with a 306 cabriolet (n3?) pump its had about 5 hours of use before it blew out the top pinion seal, it was coming out like a fountain, as i was pulling into a carspace, and it had some very hard driving the day before. im yet to dissasemble it to check whats gone wrong, but im after some advice as i suspect I may be correcting a symptom not a cause. My thoughts are ive nicked one of the high pressure seals inside (and the top one that blew out is just a dust seal more than anything, not designed for pressure), or scored the housing, the pump has a faulty pressure release valve or ive just used the wrong fluid. I used a castrol version of dextron III. Advice/thoughts/criticism? Much appreciated.
  5. I have a problem with my fuel pump not switching off when turning the engine off. Sometimes it switches off as usual, sometimes it will continue to hiss and whir away for a couple of minutes and sometimes it will carry on overnight without me realising ! Trouble is it seems to be killing my battery as it didn't have enough juice to even power the clock inside the car this morning. I'm also not sure if this will waste fuel at all ? Baz suggested to me that it could be shorting out a while back, but I honestly don't know where to start with that part of the loom.
×