Jump to content

Welcome to the brand new 205GTIDrivers.com website! We hope you'll enjoy it! Read the full notice here.

Sign in to follow this  
Aroton

205 Enigine Tu3S 1.4 Mono Jetronic Cutting At Full Throttle

Recommended Posts

Aroton

When reaching high rpm in any gear (pedal is pressed down at max) the car just cuts out. When lifting the pedal just a bit, the enigine comes back again and accelrating full out. The enigine is only cutting when the pedal is pressed down at max and reaching high rpm. Can it be the coilpack, fuelpump, sparkplugs or cables?

 

The engine starts just fine in all weather conditions. Idling is and have always been uneaven. It drives fine until you need to accelrate and reach high rpm, then engine dies/cutting. If I keep the pedal inn for a while when the enigine have died, the speed decreases and suddenly it starts again and then its starting to missfire and twitching until the pedal is adjustet a bit upwards. When the pedal is adjustet a bit up the engine runs fine and accelrating to toppspeed in any gear.

 

The car is a 1990 Peugeot 205 XR with a 1.4 80bhp TU3S mono jetronic with 54600 miles.

New parts:

-New sparkplugs and distributor cap, lambdasonde, filters etc.

-New idle control valve/stepper motor

-New cylinderhead with valves and gaskets
-All the sensors attatched to cylinderhead are new.

-New cambelt, and its attatched correctly.

 

IMAG0006_zpswwxkcndp.jpg

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×