Jump to content

Welcome to the brand new 205GTIDrivers.com website! We hope you'll enjoy it! Read the full notice here.

  • Welcome to 205GTIDrivers.com!

    Hello dear visitor! Feel free to browse but we invite you to register completely free of charge in order to enjoy the full functionality of the website.

ladderboy

Low Voltage at coil

Recommended Posts

ladderboy

Won't start. Checked fuel delivery, all good. Checked sparks. First one is good, then after that they're there, but pretty weak. Checked LT voltage at coil, only 10.5v despite 13v at battery. What could be causing the drop? Wiring looks pretty simple between coil and instrument cluster, but I can;t find wiring diag for cluster. I do have a Cobra Alarm/immobiliser fitted. Could this be causing it? Wondered if I should just pull the whole thing out..........

Share this post


Link to post
Share on other sites
Telf

Battery is connected almost directly to the coil. I'd check the condition of your battery terminals/crimps

Share this post


Link to post
Share on other sites
jackherer

As a test run a wire straight from the battery positive to the positive terminal on the coil.

 

The immobiliser is probably just spliced into the wires from the ignition barrel, it's worth checking the connections because often they are very badly installed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×